[migration système] Debian 8.0 pour wri

Problème/bug rencontré sur le site, évolution/amélioration à proposer
Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

[migration système] Debian 8.0 pour wri

Message par sly » 29 nov. 2015, 18:45

Debian 8.0 est sortie et je pourrais passer tout le serveur de wri à cette version.

Principales évolutions qui nous concerne :
- postgis 2.1.4
- php 5.6.14
- PostgreSQL 9.4

Bien évidement, les nouveautés ne doivent pas nous faire oublier les incompatibilités qui risquent fort de concerner ce bon vieux phpBB ou même le code du site dont certaines parties ont au moins 10 ans et qui pourrait entraîner quelques difficultés ou mises à jour plus ou moins propre à faire.

Rien ne presse mais si vous pensez que ça peut valoir le coup, je peux réfléchir à y passer, fixer une date avec vous ou nous pourrons intervenir pour les dernières corrections.
Modifié en dernier par sly le 01 déc. 2015, 00:14, modifié 2 fois.

Avatar du membre
Dominique
Messages : 2605
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 29 nov. 2015, 19:50

Prêt à donner un coup de main.
Tu peux faire une machine de test (pas forcément puissante) ?

Avatar du membre
leosw
Messages : 473
Enregistré le : 28 févr. 2013, 18:28
Localisation : Sud Ouest
Contact :

Message par leosw » 29 nov. 2015, 20:41

Je suis disponible cette semaine (en soirée) pour corriger les bugs qui sont de mon ressort.

Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

Message par sly » 29 nov. 2015, 20:41

Tout est virtualisé donc je peux "pas trop difficilement" dupliquer la machine virtuelle qui fourni wri et comme on utilise un dépot git centralisé externe, ça devrait nous permettre d'éviter trop de duplications.

Je n'y avais pas nécessairement pensé (mon inconscient l'a sans doute supprimé car il sait que ça nécessite plus de travail)

Mais je vais faire ça, ça ne prend pas de risque pour la prod et ça nous permet de mesurer le niveau de compatibilité sans stress

Avatar du membre
Dominique
Messages : 2605
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 29 nov. 2015, 21:59

Par curiosité, tu virtualise avec quoi ? XEN ?

Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

Message par sly » 29 nov. 2015, 22:32

virtualbox

Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

Message par sly » 29 nov. 2015, 22:33

la VM est donc dupliquée et upgradée en quelques minutes. Maintenant, toute la galère, c'est postgresql

Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

Message par sly » 30 nov. 2015, 23:54

Et quelle galère, on est loin de mysql ou tout se fait bien intégré à l'OS
Bon dump, redump, gis, tout ça, ouf, j'y suis, j'ai un postgresql 9.4 qui tourne.

Voilà les adresses de test correspondant à vos espace perso :
http://leo-test.refuges.info/nouvelles/
http://dom-test.refuges.info/nouvelles/

et le mien :
http://sly-test.refuges.info/nouvelles/

Pour accéder au code, c'est comme le serveur principal sauf que vous remplacez l'adresse serveur par test.refuges.info que ça soit en ssh, sftp ou en ftp

Pensez à activer le mode debug (dans config_privee.php) pour obtenir ce genre d'erreur :
http://leo-test.refuges.info/

Et comme j'ai forcément oublié plein de trucs, demandez moi si vous avez un doute

Avatar du membre
leosw
Messages : 473
Enregistré le : 28 févr. 2013, 18:28
Localisation : Sud Ouest
Contact :

Message par leosw » 30 nov. 2015, 23:57

Je m'occupe pour ma part de l'API, mais je ne garanti rien sur la date où ce sera au point.

Je dirais ici quand les soucis de mon côté seront fixés.

Léo

Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

Message par sly » 01 déc. 2015, 00:30

Je suis agréablement surpris par le peu d'erreur (de prim abord) que je rencontre

J'en ai corrigé une liée à postgis 1.5 -> 2.1 (git pull à faire) mais je n'en vois pas d'autre de flagrante. Même phpBB semble supporter cette mise à jour.

Avatar du membre
Dominique
Messages : 2605
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 01 déc. 2015, 12:20

Ben ça semble bien côté cartes.
Même l'édition des massifs fonctionne.

Par contre, pb pour uploader une photo

Warning: copy(/home/users/dom/www.refuges.info/photos_points/16813-originale.jpeg): failed to open stream: No such file or directory in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 326

Warning: copy(/home/users/dom/www.refuges.info/photos_points/16813.jpeg): failed to open stream: No such file or directory in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 331

Warning: imagecreatefromjpeg(/home/users/dom/www.refuges.info/photos_points/16813.jpeg): failed to open stream: No such file or directory in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 366

Warning: imagesx() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 367

Warning: imagesy() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 368

Warning: Division by zero in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 370

Warning: Division by zero in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 373

Warning: imagecreatetruecolor(): Invalid image dimensions in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 375

Warning: imagecopyresampled() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 376

Warning: imagejpeg() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 378

Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 379

Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 380

Warning: copy(/home/users/dom/www.refuges.info/photos_points/16813.jpeg): failed to open stream: No such file or directory in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 334

Warning: imagecreatefromjpeg(/home/users/dom/www.refuges.info/photos_points/16813-vignette.jpeg): failed to open stream: No such file or directory in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 366

Warning: imagesx() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 367

Warning: imagesy() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 368

Warning: Division by zero in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 370

Warning: Division by zero in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 373

Warning: imagecreatetruecolor(): Invalid image dimensions in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 375

Warning: imagecopyresampled() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 376

Warning: imagejpeg() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 378

Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 379

Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /home/users/dom/www.refuges.info/modeles/commentaire.php on line 380

Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

Message par sly » 01 déc. 2015, 15:45

ça marche sur mon instance :
http://sly-test.refuges.info/point/4082 ... Debian-80/

Il doit te manquer le dossier photos_points sur la tienne non ?

Avatar du membre
Dominique
Messages : 2605
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 01 déc. 2015, 15:56

sly a écrit :Il doit te manquer le dossier photos_points sur la tienne non ?
Ha ben oui. +777.
Je ne vois rien d'autre qui cloche.

Avatar du membre
sly
Messages : 3734
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie

Message par sly » 01 déc. 2015, 16:29

J'attends quelques jours que leo regarde la partie qu'il gère et ensuite je ferais la migration sur www.refuges.info, c'est là que nos aimables utilisateurs auront plus de chances de trouver des bugs !

Avatar du membre
Dominique
Messages : 2605
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 01 déc. 2015, 17:35

Les API fonctionnent au moins pour la partie utilisée par les cartes et l'import dans chemineur.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités