refuges.info passe à l'heure d'IPv6

Problème/bug rencontré sur le site, évolution/amélioration à proposer
Avatar du membre
sly
Messages : 3789
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

refuges.info passe à l'heure d'IPv6

Message par sly » 14 févr. 2016, 17:58

Plus pour me faire plaisir que pour une vrai utilité à court terme :
le site www.refuges.info est maintenant accessible avec le protocole "ipv6" qui est annoncé (depuis 18 ans !) comme successeur de celui qui fait fonctionner Internet depuis 1981 "ipv4".

Tout ceux dont la connexion n'est de toute façon pas compatible avec ipv6 ne devrait constater aucun changements. Pour les autres, peut être que des petits bugs pourraient arriver sur le forum.
(Et oui, ce bon vieux phpBB n'a pas 18 ans mais ne supporte pas bien les sessions d'utilisateur connectés en ipv6)

Avatar du membre
Claude Mauguier
Messages : 2131
Enregistré le : 08 avr. 2011, 15:31
Localisation : Isére

Message par Claude Mauguier » 14 févr. 2016, 18:11

sly a écrit :Plus pour me faire plaisir que pour une vrai utilité à court terme :
le site www.refuges.info est maintenant accessible avec le protocole "ipv6" qui est annoncé (depuis 18 ans !) comme successeur de celui qui fait fonctionner Internet depuis 1981 "ipv4".

Tout ceux dont la connexion n'est de toute façon pas compatible avec ipv6 ne devrait constater aucun changements. Pour les autres, peut être que des petits bugs pourraient arriver sur le forum.
(Et oui, ce bon vieux phpBB n'a pas 18 ans mais ne supporte pas bien les sessions d'utilisateur connectés en ipv6)
Bon, je suis allé voir "ipv6" sur la toile...et comme je ne parle ni l'algonquin ni le post-sybillin, j'en conclus que je n'en sais pas plus ou presque.
Je fais comment pour savoir si moi, sous Windows10, Firefox et le reste je suis ipv4 ou 6 ? Au fait que je n'ai pas (encore) vu poindre de big-bug général ?
Ceci dit, du moment que je peux venir grogner ici sans histoire, je m'en gratte la truffe... :ours:

Avatar du membre
Dominique
Messages : 2638
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 14 févr. 2016, 18:30

Claude Mauguier a écrit :Je fais comment pour savoir si moi, sous Windows10, Firefox et le reste je suis ipv4 ou 6 ? Au fait que je n'ai pas (encore) vu poindre de big-bug général ?
Ceci dit, du moment que je peux venir grogner ici sans histoire, je m'en gratte la truffe... :ours:
Ceci n'a rien à voir avec ton PC mais avec ta ligne.
Pas de panique, derrière une BOX, tu est très certainement en IPV4.
Pour en être absolument sûr, tu peux appeler: https://www.iplocation.net/
Si ton adresse est du genre 123.234.012.210, tu es en IPV4
Si elle est de la forme 2001:0db8:0000:85a3:0000:0000:ac1f:8001, tu es en IPV6

*** EDIT *** Tu peux aussi tapper le petit carré [IP] à droite de ton message dans ce forum.
Si ton adresse est du genre 123.234.012.210, tu es en IPV4
Modifié en dernier par Dominique le 14 févr. 2016, 18:37, modifié 1 fois.

Avatar du membre
Dominique
Messages : 2638
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 14 févr. 2016, 18:36

sly a écrit :Plus pour me faire plaisir que pour une vrai utilité à court terme :
le site www.refuges.info est maintenant accessible avec le protocole "ipv6" qui est annoncé (depuis 18 ans !) comme successeur de celui qui fait fonctionner Internet depuis 1981 "ipv4".

Tout ceux dont la connexion n'est de toute façon pas compatible avec ipv6 ne devrait constater aucun changements. Pour les autres, peut être que des petits bugs pourraient arriver sur le forum.
(Et oui, ce bon vieux phpBB n'a pas 18 ans mais ne supporte pas bien les sessions d'utilisateur connectés en ipv6)
Pour commencer, la localisation n'a pas aimé : modcp.php?mode=ip&p=25645&t=7240&sid=74 ... f43463cbf3

Avatar du membre
sly
Messages : 3789
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

Message par sly » 14 févr. 2016, 18:37

Dominique a écrit : Pas de panique, derrière une BOX, tu est très certainement en IPV4.
Je suis chez le FAI "OVH" et l'IPv6 est maintenant activée par défaut. Les autres l'ont en option.
Dominique a écrit : Pour en être absolument sûr, tu peux appeler: https://www.iplocation.net/
Et sur le forum ici même, un mini bouton en haut à droite de chaque post de chaque personne indiquant "IP" (oui il faut de bon yeux tellement c'est petit) donnera, si cliqué, l'adresse réseau de celui ayant mis le message.

x.y.z.t -> la personne est en V4
a:b:c:d::truc -> v6

Avatar du membre
sly
Messages : 3789
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

Message par sly » 14 févr. 2016, 18:40

Dominique a écrit : Pour commencer, la localisation n'a pas aimé : modcp.php?mode=ip&p=25645&t=7240&sid=74 ... f43463cbf3
Tu l'as eu comment ce lien ?

Avatar du membre
sly
Messages : 3789
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

Message par sly » 14 févr. 2016, 18:45

J'ai retrouvé 25645, c'est mon message tout en haut de ce fil de discussion.
Par contre, si je clique sur ip->localisation je n'ai plus le même "token" que dans ton lien.

Comment l'a tu eu ?

Avatar du membre
Dominique
Messages : 2638
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 14 févr. 2016, 19:21

sly a écrit :J'ai retrouvé 25645, c'est mon message tout en haut de ce fil de discussion.
Par contre, si je clique sur ip->localisation je n'ai plus le même "token" que dans ton lien.

Comment l'a tu eu ?
Oui, en cliquant sur ton message.
Et il me redonne le même token. Probablement mon n° de session PhpBB.

Avatar du membre
sly
Messages : 3789
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

Message par sly » 14 févr. 2016, 19:33

Ben oui, je suis bête. Mais je croyais que ce "session id" était dans le cookie. Bon, avec phpbb c'est au petit bonheur la chance.

En tout cas, il est normal que j'obtienne :
Invalid_session

Donc, ce n'est pas le problème que tu évoques, mais celui qui fait que quand on clic sur "Chercher l'adresse IP" il n'y arrive pas ?

C'est tout à fait normal en fait, car mon adresse IPv6 n'a pas de "reverse", c'est une particularité de ma connexion mais ça n'est pas un bug lié à phpbb vs ipv6 il me semble.
A moins bien sûr que cette "recherche d'ip" ne marche pas avec une ipv6 qui a un reverse... je tente

Avatar du membre
sly
Messages : 3789
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

Message par sly » 14 févr. 2016, 19:35

pouf ?

Avatar du membre
sly
Messages : 3789
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

Message par sly » 14 févr. 2016, 19:36

c'est bon, ça marche aussi en ipv6 le reverse

Avatar du membre
Dominique
Messages : 2638
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Message par Dominique » 14 févr. 2016, 19:38

sly a écrit :c'est bon, ça marche aussi en ipv6 le reverse
Rha zoo. C'est beau :saint:

Répondre