Page 1 sur 1

[contournement] Liens externes inopérants

Posté : 16 mars 2016, 17:43
par Claude Mauguier
Lorsque je tente d'insérer sur une fiche un lien externe vers une photo, si celui-ci est trop long...il se scinde et ne fonctionne pas. Enfin, je suppose que c'est une question de nb de caractères et pas autre chose.
exemple :
http://girovagandoinmontagna.com/gim/la ... 3642;image

Posté : 16 mars 2016, 18:02
par Dominique
Ce n'est pas un problème de longueur mais de caractères '/() pas usuels dans un lien.
Un gros casse tête de bbcode que je laisse à notre spécialiste :sleep:

Posté : 16 mars 2016, 18:15
par sly
dans l'exemple ci donné, c'est plutôt le ' dans l'adresse (on voit que c'est bleu jusqu'a "cima-d"). Là, franchement, fallait oser, mettre un ' dans une adresse !

Le truc c'est que si je commence à accepter les ' dans les urls, on va avoir des truc foireux du genre :

Hop machine m'a dit : 'va voir sur http://www.google.fr/pouf' et ça ne marchera plus

Bref, si ça déconne avec une url, le mieux c'est la syntaxe bbcode complète :
[ url=http://adresse]là bas[/url ]


A noter toutefois que des urls vers une image ne me semble pas le mieux, on sait que dans le temps, refuges.info dure plus longtemps que tous ces sites, et ça finira immanquablement sur du "url inaccessible"

J'en suis presque à préférer pas de lien image que lien précaire.

C'est d'ailleurs ce choix qui a fait, en plus d'un problème de copyright, que les balises [img] sont pas autorisées sur les fiches