[clos] Comportement bizarre de la mini carte des fiches

Problème/bug rencontré sur le site, évolution/amélioration à proposer
Avatar du membre
sly
Messages : 3419
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie
Contact :

[clos] Comportement bizarre de la mini carte des fiches

Message par sly » 05 juin 2017, 17:11

Salut,

Quand je suis sur une fiche et dans le secteur de la mini carte je choisi "ign" ça devient plus grand mais ça ne passe pas à IGN pour autant.
Quand je clique pour me rendre sur "Aller sur la page des cartes" ça va sur /nav mais ça ne va pas à l'endroit attendu (le point de la fiche) mais selon le cas soit le dernier endroit que j'ai visité, soit la france très dézoomé

Je ne saurais dire de quand ça date, mais ça doit être récent...

Avatar du membre
Dominique
Messages : 2388
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Re: Comportement bizaarre de la mini carte des fiches

Message par Dominique » 05 juin 2017, 18:51

Hum. Très récent alors car je n'ai pas encore le bug (FF, Chrome, IE sous win10)
Le lien entre la fiche et nav est fait par les cookies. Tu n'aurais pas un réglage bizarre de cookies ?

Avatar du membre
sly
Messages : 3419
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie
Contact :

Re: Comportement bizarre de la mini carte des fiches

Message par sly » 05 juin 2017, 21:34

j'ignorais que c'était avec des cookies...
Toutefois je ne pense pas avoir activé de réglage, et même dans une fenêtre de navigation privée (sensé de récupérer aucun cookie ancien) j'ai le même comportement.
Iceweasel 38.6.0 sous linux (clone de firefox qui change juste de nom en théorie)

Au passage, des contrôles de carte ont disparus :
page-iceweasel-linux.png
page-iceweasel-linux.png (513.63 Kio) Vu 1055 fois

Avatar du membre
sly
Messages : 3419
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie
Contact :

Re: Comportement bizarre de la mini carte des fiches

Message par sly » 05 juin 2017, 21:43

désolé pour le monologue, mais comme toujours c'est en prenant son temps pour faire son rapport de bug que l'on constate des trucs étranges qui mettent sur la piste...
Ce bug ne se produit qu'en https et pas en http...

Avec en console de "sécurité" l'alerte indiquant :
Blocage du chargement du contenu mixte actif (mixed active content) « http://www.overpass-api.de/****************

Voilà voilà, c'est donc moi le fautif, j'ai changé l'adresse d'accès à l'overpass API il y a peu et je n'ai pas fais le rapprochement (celle sur api.openstreetmap.fr étant coupée) et j'ai remis une url d'accès en http.
En remplaçant ça en https c'est bon.

Se pose par contre la question de savoir si c'est un problème ou pas pour ceux qui sont en http et qui ne voudraient pas de latence/calcul superflux lié à https ?

Avatar du membre
Dominique
Messages : 2388
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Re: Comportement bizarre de la mini carte des fiches

Message par Dominique » 05 juin 2017, 22:59

sly a écrit :
05 juin 2017, 21:43
Voilà voilà, c'est donc moi le fautif
Quand le chef dit qu'il a faut, le chef à toujours raison :)

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités