[corrigé] Non connecté ===> forum mod visible

Problème/bug rencontré sur le site, évolution/amélioration à proposer
Avatar du membre
Claude Mauguier
Messages : 1576
Enregistré le : 08 avr. 2011, 15:31
Localisation : Isére

[corrigé] Non connecté ===> forum mod visible

Message par Claude Mauguier » 30 mai 2017, 14:59

- J'arrive sur le site : je dois cliquer sur "connexion" afin d'être reconnu (cookies acceptés, sauf cookies tiers), alors que c'était inutile auparavant.
- si je ne le fais pas et que je passe sur le forum : la rubrique "le coin des mod" est visible tout de même... :shock:
- Je suis donc reconnu quelque part, mais tout en ne l'étant pas... bizarre.

Avatar du membre
Dominique
Messages : 2386
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Re: Non connecté ===> forum mod visible

Message par Dominique » 30 mai 2017, 15:09

Hum ? Ce système de sessions et de reconnections du forum est d'une complexité diabolique.
Je pensais avoir capturé tous les cas mais il y a des configurations qui m'échappent !
Bon. Je me replonge dans le code....

Avatar du membre
leosw
Messages : 439
Enregistré le : 28 févr. 2013, 18:28
Localisation : Sud Ouest
Contact :

Re: Non connecté ===> forum mod visible

Message par leosw » 31 mai 2017, 15:38

Holà,

Pour l'information, j'ai le même soucis de mon côté,
Bonne chance !

Léo

Avatar du membre
sly
Messages : 3417
Enregistré le : 29 févr. 2004, 18:59
Localisation : Chambéry - Savoie
Contact :

Re: Non connecté ===> forum mod visible

Message par sly » 31 mai 2017, 18:01

Pareil, mais ça doit être récent, je suis (presque) sûr de ne pas avoir eu ça il y a quelques jours.

Avatar du membre
Dominique
Messages : 2386
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Re: Non connecté ===> forum mod visible

Message par Dominique » 31 mai 2017, 20:40

Effectivement, ça a l'air plus fréquent depuis 2 ou 3 jours.
J'ai changé l'algorithme d’auto-connexion le 26 mai (j'avais mis quelque chose de trop permissif et on pouvait tomber dans le cas où on pouvait accéder aux fiches sans être connecté au forum). Maintenant, il est trop restrictif et ne gére pas de façon identique certains cas de reconnexion.
J'ai essayé de coller au plus prés à l'algo de connexion du forum mais il est complètement imbitable : session de 1h, après il y a "reconnexion" avec une combinaison de "persist login" basée sur l'adresse IP, l'agent explorateur, la liste des bots et l'âge de la petite fille du capitaine.

Je vais faire une autre tentative avec une première vérification assez restrictive par SQL en fonction des cookies (qui devrait traiter la navigation courante sans surcharge) et appeler le forum en AJAX pour les cas de reconnexion de façon à lui faire faire le boulot de façon cohérente pour les fiches et le forum.

En attendant, j'ai passé la durée de session à 1000 heures de sorte qu'on ne retombera dans ce problème que si on ne s'est pas connecté pendant 40 jours : ça devrait en calmer certains :)

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 9 invités