[resolu] gras = rouge ??

Problème/bug rencontré sur le site, évolution/amélioration à proposer
Avatar du membre
Claude Mauguier
Messages : 2227
Enregistré le : 08 avr. 2011, 15:31
Localisation : Isére

[resolu] gras = rouge ??

Message par Claude Mauguier »

Sur ce fil : http://www.refuges.info/forum/viewtopic ... 223#p32223
J'ai introduit un texte d'avertissement, copié sur une fiche (il était noir sur blanc au départ), en le complétant avec les balises [b [/b.
Du coup il se retrouve directement en rouge, malgré l'absence de balise [color=][/color]. Bizarre...

Avatar du membre
sly
Messages : 3875
Enregistré le : 29 févr. 2004, 17:59
Localisation : Chambéry - Savoie

Re: [mcbug] gras = rouge ??

Message par sly »

Juste pour confirmer que c'est bien un bug, que gras ça ne devrait pas finir rouge, et qu'il s'agit sûrement d'une bagarre idiote entre le style de notre site et celui du forum.

A vu de nez : https://developer.mozilla.org/fr/docs/W ... ent/strong
Ce sont les développeurs du style du forum phpBB qui auraient mal lu la doc html <strong> -> "indique que le texte a une importance particulière ou un certain sérieux voire un caractère urgent"
L'interface parlant de texte en gras, c'est une mise en forme, et pas une sémantique, ils n'auraient pas dû utiliser <strong> mais une div avec une classe indiquant du gras.

Mais bon, devant l'ultra haute importance de ce bug, je vais tranquillement le noter pour plus tard.
Sauf si notre expert forum nous déniche la combine pour que le bold reste bien bold

Avatar du membre
Dominique
Messages : 2732
Enregistré le : 08 avr. 2006, 21:58
Localisation : Chaville 92
Contact :

Re: [mcbug] gras = rouge ??

Message par Dominique »

Effectivement, c'est dans le template de prosilver de 3.2.9.
Bon, on ne réfléchit pas trop, un CSS de plus dans la zone "Modification du style du forum" et hop, les forts retrouvent leurs couleurs ;)

Répondre